Disable transliteration to hiragana for katakana

Hi, I don’t think anyone else has mentioned this yet:

I think the Original + Hiragana setting for transliteration in Japanese should not transliterate katakana, or at least there should be an option to turn this off while keeping furigana for Kanji.

I’ve learned katakana but I would like to be faster at reading it, and with equivalent hiragana next to it I default to reading the hiragana since I’ve known it for much longer.