Hide transliterations for known words acting irregularly on "white" characters

  • Please provide a link to the video/page you have the bug: Any Netflix show, but currently watching https://www.netflix.com/watch/81622859?trackId=14170286
  • Please let us know from which country you are having the bug (YT and Netflix have different content and subtitles depending on the country the user is located): US Netflix
  • If relevant, please let us know what are the configuration of languages you try to have: Subtitles are set to simplified Chinese. Under “Transliteration visibility” I have replicated this issue with both “Hide for known words” and “Hide for marked and known words”

This hides transliterations for green text and shows it for purple. Orange depends on which setting I use above.
Sometimes transliteration is missing for white characters.

I have noticed that the characters which lose transliteration aren’t in the dictionary if I search them. For example, on this line I have marked 是 (a very common character which is in LR’s dictionary) as unknown to illustrate both behaviors:
The white characters without transliteration above them are 月族 which means “moon tribe.” This is a concept specific to the show, and so doesn’t show up at all under Saved Items->All Words (however it does show up if I search it in the little dictionary pane on the right side of the screen, if that is relevant). This distinction is consistent across all “white” vocab which does not show its transliteration.

If it is helpful for debugging – manually marking 月族 as “do not learn” (purple) does make the pinyin appear.