youtube translation language not showing up

my youtube translations arent showing up. under my target language the translation is only a short line. i tried other languages and they show up fine. the english doesnt. and yesterday i couldnt get italian translations in english videos.

is something wrong?


Can you post a screenshot and a link to the video? I’ll check it tomorrow, just going to bed.

1 Like

this is all i get for english translation from italian subtitles. i have tried other languages they work fine. english does not.
(yet english translation works on channels in english) I noticed the italian was the same yesterday with english channels.

Also i tried other Italian videos. None work with english. It worked fine 3 days ago

this wasnt the only video, it was with every single italian video i tried to watch. Only subtitles that wouldnt show up were english.

1 Like

I’m having the same issue. Spanish video where the english translation doesn’t show up, but if I change it to a different translation language it works fine.

Edit: Near the end of the video the entire english translation showed up in a big paragraph along with the current single line of spanish.


yes so it must be something with english. however i tried an english video, and it will do the subtitles in english, and also if you select the translation language in english it works too.
it just shows a “-” when i watch videos in italian that i want an english translation.

I did everything too, i uninstalled the LR extention and reinstalled it didnt help either.
its frustrating as hell.

1 Like

yes this happened to me last night! i thought for a split second it was fixed, and would show up normally in the next video.

this happens at the end of the video… and a couple of subtitles show up after this happens a minute to the end of the video.
then the next video has no english translation

Having this exact issue as well. Anyone find a fix? I’ve removed and reinstalled the extension and it’s still broken.

I’ve noticed though specifically that it seems to have no problem translating videos that have actual Spanish captions and not auto-generated.


Me too live same problem… Its not working. Big text pops up all of a sudden. And then nothing is working…


Same here - every video translation has a “-” where there should be the English translation, however the last line of dialogue in the video dumps the entire text there. Been going on for serveral days now. Thanks for this amazing product, hope it works again soon!!!

1 Like

i have the same problem , but i think there something wrong with youtube, because this problem also in ipad :smile:

1 Like

Same with me: english translations don’t appear at all, translations into other languages appear in subtitles, but not int the sidebar on the right.

I hope it’s possible to fix
Thank you for a wonderful app!

1 Like

Youtube doesn’t seem to be able to fix this problem. language reactor should use their own servers for youtube translation. At least we will get rid of such youtube-related problems.

Having the same problem…I’ve spent all day trying to fix this. LR used to work great to translate ENG into ESP and ESP into ENG, now it is giving me the giant paragraph at the end of the video. Thank you for all your help! Love LR…has really helped me aprender mas espanol. Gracias


Hey. There is an issue with Youtube’s internal machine translation system… if you remove the extension, and try to select machine translations of Youtube captions in the video playback menu, you will see something similar.

It’s a bit surprising to see something like this break on Youtube…

I’m hoping they fix it shortly.

Seems to be fixed on youtube finally!

it seems to be working now! thank you!
i appreciate all the work that you all have done for this extension.
youve made one hell of a difference for me.
thank you again

awesome! it is working again! to anyone who helped thank you!

I also had a problem, unable to translate from English to Thai.

Have you found a solution to this problem?
I have the same problem, translation from English to Ukrainian is not possible shows “-” Translation from Ukrainian to Russian at the same time works.

1 Like

Its not working again. Same problem

1 Like