Trouble with media and Anki importing

Hey sorry for the hassle but I recently got the pro version to try out the Anki importing but I can’t seem to get the media to be imported. I’ve followed the steps that were outlined in the help document (I think) I tried copy and asting all the media into the media file and importing. Not sure If i have to align the media and the cards manually or if im just doing it wrong. Thanks in advance.

2 Likes

Which help document? Loading the text itself is easy enough. However, there doesn’t seem to be a systematic way to import the audio and image files. Also, the HTML doesn’t seem to display with my Anki v2.1. Could really use a rough guide.

Would be keen on buying the pro version if I can get this to work…

https://extension.dioco.io/export.html

I can also get the text to work but even then I might need to find a good format and use the CSV export as the machine translations sometimes don’t help at all.

I got it to work by following the guide. One problem I had was not having the ‘Cloze’ note type. I solved this by adding it under Tools > Manage Note Types

Make sure you move the image and sound files to the designated folder:

  • Mac: ~/Library/Application Support/Anki2/User/collection.media/
  • Windows: C:\Users\Administrator\AppData\Roaming\Anki2\yourankiaccountname\collection.media

Media folder for Mac: https://anki.tenderapp.com/discussions/ankidesktop/33231-how-to-find-the-media-folder-on-a-mac
Media folder for PC: https://superuser.com/questions/963526/where-does-anki-store-media

I did all that you said but when I look at the csv “items” generated I just see one filed with the the word in it?
I’ve no idea what I’m doing wrong and I wish there ware more of a guide. I assume many are doing fine?

image

I think Og is aware of this problem and will have it fixed shortly. Sorry, instructions are a bit thin at the moment still. :-/

2 Likes

Yeah I am struggling with adding the media and the flashcards. I think I’ve followed all the steps but I am struggling with what to do when adding the CSV file. It just gives me one card in anki…

I have added a video of my efforts here.

Hi
I have tried to watch you video. It was very grained I did not manage to see you ANKI import setting.

IN LLN
Make sure that the export setting “Only new items, since last export” is turned off in LLN export setting if you want it all.

IN ANKI

  1. Try to copy the files in the unpacked media-map into the media.collection before you import files to Anki.

  2. make sure that you use the following setting

type: cloze
fields separated by: tab
allow HTML in fields

I did actually manage to get it working a little while later. It is good so far. Two things that would improve it: being able to turn off the translation in the anki file so that the slides don’t have any English; the original audio from the tv show would be so good!

Thanks for the advice!

Hi

What is it that you changed that made it work?

How do you prefer to use LLN for language learning and Anki and for which language?

Ps. I am just an ordinary forum member like you.

I just purchased Pro yesterday. I am trying to export a phrase with media to Anki and into a Cloze card. I am running into similar problems. Following the instructions, once the zip file was in my download file, I unzipped it. I then copied the folder which includes the media folder and the items file (excel) to the collection.media folder. Then I go to Anki tools>import. The only file that it “sees” is the items file because it is looking for “text separated by tab or semi-colon”. That happens to be the “items” excel file. It does not “see” the media folder. I select with Cloze card, fields separated by tab and html allowed. All the others options are as shown in the directions mentioned by others in this topic. Result: Nothing This is the only purpose I have for purchasing the Pro feature so I am hoping to understand the step that I am missing.

3 Likes

Just wondering how this was going? I have not tried again after reply into the original problem. I posted to repeating tag as my only result. I’ll try to set it up again this weekend but if there’s anything working toward a steb-by-step approach I’d love to know? :slightly_smiling_face:

1 Like

You have to copy the content of the media-folder in the zip-file, the media-files directly into the collection.media folder. Anki do not support subfolders for mediafiles.

Yes, oefu, has it right. I got some help from the Anking (Anki Palace) people. You download your file from LLN to whereever you want. For me, it is the downloads file. I extract the zip file right there. I get a media file and an items (speadsheet) file. I open the media file and copy or drag the contents into the collection.media. (no sub-files) Then I open the Anki program and import the item file (still in my downloads file). Evidently that file finds the media files that we just dropped into the collection.media file. Works.

2 Likes

This works for you? It’s never worked for me. Anki shows the file name of the image (1616356726107_next.jpg), but not the image itself. I’ve tried encasingh int in HTML tags, but that didn’t work eitherh.

Same for me. Still cant work it out after like 3 months.

Have not done it in a while. Will give it a try again over the weekend.

Yes, it worked. Once again, I “starred” the dialog that I wanted. This saves it. I went to export. The usual instructions were there. I hit the export button. It went to my download file. I unzipped it and got two items. The media folder and the items. I opened the media folder and dragged two jpeg and 1 audio file over to the collection.media folder and just dropped them in. Then I went to Anki, import. I did not adjust to tab. Just left the setting where it was. I think that I had to select "include media. I ended up with a cloze card card with two photos, one audio file all appropriate positioned on the front and back. I think that I can play with it if I want things positioned differently.

1 Like

Thanks All. I have yet to try the suggestion/s. I’ll hopefully give it a go this week.