Anki Export / Import

I just successfully did the Anki export today for Windows and the process was exactly as described on the LLR website. Maybe it’s a Mac Anki problem.

Now if only I could figure out Anki enough to change the Cloze card format to be usable, with Cloze audio only on the front and the translation and transcription on the back.

Are there any plans to add the native source audio as an export option? There’s another subscription program out there that does it, but I’m enjoying LLR more.

Would also love to know this and to hear back from the developer :slight_smile: Yes it probably is a problem relating to Mac. For the Cloze thing I’d recommend the Anki forum as they’re really responsive there.

This is absolutely not a Mac problem. I have a Windows and it’s showing Russian AND English on the front of the flashcard. I have no idea how to fix this and the developer needs to do something about it. Hire someone to make a video from Fiverr. Make one yourself. This is the reason why we’re paying. The service is useless if we can’t test ourselves

1 Like

Hello everyone, sorry for the late reply.

So, @Zachary_Gottlieb , I’ve checked the video, and it seems that your anki import settings are wrong.

Below is a screenshot of the help explanation we provide. Be sure to :

  • Select the CLOZE card type
  • Select the Tab field seperator (and not Space !)
  • check the Allow HTML in fields

For these three settings, it was wrong in the video I saw

Can you try again and let me know if it words ? If not, please send again a video, or let’s arrange a screen sharing meeting :slight_smile:

Have a good day !

Yes, it now worked. The reason I didn’t have those settings active is because in the instructions you copy/pasted at the beginning it did not mention anything about these settings.

I know you’ve had your heads down coding, but this forum is not super active - for paying customers you should really check in more than once a month to be honest.

1 Like

Thank you for helping to fix it.

1 Like

Hi @Zachary_Gottlieb , I’m really glad it worked for you when you followed the instruction of the documentation :slight_smile: .

Have fun learning your target languages !

Yup. I’d really recommend making a Youtube video for it. It wouldn’t take long and others are obviously having difficulty as well judging by this thread.

hi. did you get the audio working?

Hi I had similar issues in the import process. I had two specific issues:

  1. You say to " * Start the import by referring the .CSV file that was generated by Language Reactor" in your instructions, but you don’t say what to do with the other media folder, if anything.
  2. After importing the .CSV file both the English and Spanish are on the same side. I did the step where you choose “cloze,” “tab” and “html.” Is there another step in the process needed?

Update the thread if you’re still having problems and I’ll help you through - just a user here, but I’m pretty experienced with Anki.

Same goes for anyone else trying to export to Anki - happy to help anyone. The problems here are all easy fixes if you understand Anki a bit more

please help me as there is no audio
Version ⁨2.1.54 (b6a7760c)⁩
Python 3.9.7 Qt 5.15.2 PyQt 5.15.5

Audio is back for me, but now I have all the translations on the same side. I haven’t changed anything in the parameters…
Help !

I have fixed the audio by putting the media data manually in the folder:
C:\Users<USERNAME>\AppData\Roaming\Anki2 \ \

Now I struggle with like Miltie with back/front/audio relations.

It would be great if you create video on YouTube. I have a lot of different little questions, I’m newbie in work with Anki. Thanks!
Regards, Edward, manager
of employee internet monitor

1 Like

Hi there, I have followed the instructions as exactly as I am able (Ive repeated it carefully so many times) and I cant get it to work.
Every card just says “word-naked lang-ja netflix noun” weirdly…
Any idea what that would be? Any help would be greatfully received

Exporting to Anki from LR is very poor. You have to use their cloze card template and even then its not very good.
I have no desire to use their predefined template, so what I do is export to CSV and include media. Then I go through and delete columns in the CSV that I do not need. Insert a row at the very top of your CSV for labeling each column.

For your images and sound, you’ll need to use the concatenate function to insert the needed HTML for anki to recognize images and audio files.

For images you’ll need to reformat to: < img src=“nameOfImage.jpg” > (remove spaces between the greater/less than symbols)
For audio: [sound:nameOfSoundFile.mp3]

This is a very tedious way of importing, but lucky, LR keeps track of your last export, there is at least one rare plus.

Then just copy your media files into your folder.

1 Like

These instructions have finally solved my Anki exporting problems… in my third month of subscription (!). Ive been pro actively googling, message board searching including here, etc. Would be great to maybe include these instructions in the ANKI export instructions. Anyway super pleased to have finally solved as its the key reason Ive been subscribing to LR.

1 Like

One appendix question in case anyone can help - I do like using Phrase Pump as well as Anki, as I can breakdown the sentences using the Language Reactor translation dictionary and also see my vocabulary colour coding while I do it.

But, my phrase pump sentences almost never show me videos from the shows Ive saved vocal from, but yet sometimes does. So very occasionally I get 2/3 cards which play the original Netflix audio, and show a screenshot (like on the Anki cards) but then it goes to plain sentences read by the dictionary voice only. Is there a setting I can change to run Phrase Pump to show only Netflix content that Ive saved words from at all?

Hi @Stuart_Piper,

Currently, you can go into your settings on the website and select “Original audio (when available)” to get PhrasePump to play original audio when it’s available in LR:

However, original audio won’t be pulled if it’s a premium “protected” video on YouTube. That will always be played as a TTS because YouTube does something to the code of those videos to prevent audio from being pulled from them.

Nor will selecting this setting option mean you won’t get sentences with TTS from Tatoeba, where LR gets their sentence examples from (as seen in PhrasePump and the “full dictionary”).

They don’t have a feature on LR yet that only shows you your saved content in PhrasePump. It comes with other sentence examples to help fill in your knowledge gaps because it was programmed that way.

I hope this helps answer your question!