Forces to original dub

Hello everyone, I need help about Language Reactor constantly pushing Netflix into switching back to original dub of the series/movies. For ex; there is a show in Danish, but I want it to watch it in another dub. When I turn on LR, it switches dub to original one, Danish. Can’t figure out how to prevent it from doing it.

1 Like

Hi @Furkan_Kaman,

If you toggle off “Force Original Tracks” in the settings (:gear:) icon for LR at the bottom where the Netflix video tool bar is you can prevent it from switching back to the original audio of the series/movie you’re watching:

LR Settings :gear: Icon

LR Settings button within Netflix bar

Toggle off “Force original tracks”


i tried it before, didn’t work :frowning: reinstalled and again switche it off but still it keeps changing

I noticed you’re not signed in.

Maybe you need to sign in for it to properly work/remember your settings?

I tried everything including signing in, redownloading it etc. I don’t know if it’s bcz of Chrome but it constantly changes it :confused: I guess i’ll just need to get used to this. Thx for trying to help tho.

1 Like

Tell me about it… you’re watching one episode in a foreign dub to learn, then the next episode comes in the original language for some reason, the same happens with subtitles sometimes, it’s not the end of the world but it IS aggravating.
I’m not even sure it’s a bug from LR, I think it happened to me even with LR turned off, Netflix is weird sometimes. And that bug never happened to me with Youtube or the beta video thing. So I guess it definitely comes either from Netflix or from the LR Netlix module thing part.

1 Like

Same issue for me. I am signed in. Force original track is disabled. It still happens if LR is disabled in the player but it doesn’t happen when the extension is disabled in the browser.

Having the same issue, it gets annoying have to change the language to the dub I’m trying to learn from every time. Force original tracks is disabled for me as well and still does it.

I just skimmed the thread but I can provide some info.

The ‘forcing originals’ option was working quite well about a year ago.

Then there was a netflix change in how they distributed the subtitles that forced me (I thought) to push the netflix player (using my bag of tricks) towards always setting the track we would use for the translation language, even when LR was ‘off’, which was unfortunate for some ppl, but, I thought necessary so that LR would have the necessary translation track available.

Recently I realised that I could do this only when LR is enabled, and should still work okay. This change, for some reason, resulted in the ‘force originals’ option misbehaving… not sure why. The code around setting subtitles is a little touchey, you have to ask netflix to change track nicely then wait around until it does change, while other things are going on… anyways.

tldr: will get this sorted out when I have a clear mind to put to the task, hopefully soon. :slight_smile:

Netflix has it’s own logic for setting audio and subtitle tracks that I don’t fully understand, previously the approach was either force the original, or try not to influence the choice.

Seems like netlfix does remember the user’s audio and subtitle choice for a particular show.

I took another look, the ‘force original’ option seems to be working as intended actually.

Two issues I can see:

– When the extension is switched on, and ‘force subs’ is off, and no subs were selected in netflix previously, the main subs will load in the translation language. This is hard to avoid. Once a sub is set, with ‘force subs’ setting off, it should be ‘sticky’ though, so not a big issue.

– ASR is disabled on every episode change… in the summer it was hot and the servers were overheating, this was an effort to try to keep the load under control. I can change that so ASR is kept on when switching episodes at least.

Will have another think tomorrow. In addition to ‘Force Original’ there could be ‘Force [language]’, that always tries to set, say, Spanish, if the extension is enabled.

Any updates? I just started using LR and have to say it is a fantastic program. Good work. I have the same issue. I think a force language could work well, at least it will automate the issue instead