[SOLVED] Spanish subtitles not working

Hi, so recently the Spanish translations have stopped , I’m only getting the English subtitles and the spanish has always worked before on Netflix. I noticed other languages are not working either. I’ve made sure hide subtitles is disabled and I am on the human translation option (machine is for pro only.)
Any ideas?

Hello, thanks for reaching out.

Could you please :

  • send a link to the video
  • let us know in which country you are ?

Thanks !

Hi There, thanks for responding - I am in the UK and for example stranger things on netflix only shows the english subtitles, and I definitely have the spanish translation on.
But on all netflix shows/movies its the same thing.

Thank you for your reply. To be on the same the same wavelength :

  • which episode / season are you trying to watch ?
  • your target language (language you want to learn) is spanish ?

Anything I try to watch on netflix doesn’t seem to be working.
Also yes, the target language is Spanish

Ah actually I just tried ‘the office’ and that had the spanish subtitles. But a lot of shows or films I try don’t seem to have them. Shall I just go from the list you have on the language reactor home page?

Ok so I have tried many things now from the language reactor catalogue only searching the UK and for example black mirror says it will work but has no spanish subtitles , also stranger things says it will work and have tried all seasons but no spanish. The only one I have found seems to be the office.

The netflix catalogue we have is not really up to date as Netflix made a lot of changes in their languages (dub and sub) availability in the recent months. So don’t rely on this for finding shows that have Spanish languages in your country.

Can you uninstall Language reactor, and try to look at the same Stranger thing episodes you tried earlier to see if the spanish sub is available ? thanks !

PS : The setting you have to set is either :

  • In LR settings : Netflix Subtitle Language = Spanish
  • In Netflix bottom right language panel : Subtitle = Spanish

Ok So I uninstalled and reinstalled but still not working. Only the ‘human translations’ seem to work like Polish and Ukrainian . It doesn’t say human translation next to Spanish. And I tried all stranger things seasons.

But it’s weird because a few months ago everything was working fine with whatever I wanted to watch, so something has changed.

So my native language is English and I’m trying to learn Spanish.
I have Netflix Audio = English
Netflix subtitle = English (they don’t offer Spanish for some reason)
Translation language = Spanish

Ah, I mean, could you please uninstall and try without installing it again ? I would like to know if the spanish sub are available for you without Language Reactor.

Thanks !

Hi Kirian, yes when I uninstall language reactor there is an option for spanish subtitles. (Some it says Spanish, and others there is a European Spanish option)

Yes. I think it’s linked to Netflix recent changes that make LR some times not working and show fewer languages than it could.

Can you go to this page : https://www.netflix.com/settings/language/ , and add the Spanish Languages to your “favorite” languages please ?
And then let me know if it works with LR.

Sorry for this inconvenience :confused:

Yes! A perfect fix, thanks so much! I was worried because love what you guys are doing with Language Reactor - it’s amazing.

I’m glad it fixed your problem ! We will see what we can do for helping learners that have similar problems as you just had.

Thanks !!