LR can ́t display two sets of subtitles at the same time

Hi, I’m from Peru. I’m trying to see the subtitles (English and Spanish) on Youtube and Netflix but they don’t appear.


Hi @Alexander_Cabanillas,

Quick question, doesn’t your source material (i.e., the videos you are trying to use the LR extension on) have both sets of subtitles available on it? (English and Spanish.)

For example, if the video only has English CC, then the LR extension cannot provide you with Spanish subtitles.

It’s a tricky limitation I have been trying to navigate since not many YouTube videos have English and Korean CCs. (Note: I’m learning Korean.)

However, I did notice (as a Pro User) that some of the videos (the videos that—at the very least—have Korean CC only) can have English translations (probably due to the machine translation feature Pro users have:

Hi @joan_LanguageProcess
Yes, all the videos I’m testing have the transcript. Yesterday I was watching the same videos with both subtitles.
I already tried on different computers and the same thing happens, only appears a dash.
P.S: I’m a pro user.


Yes, I just noticed this this morning:

Video Link: 뭐야 요즘 일본애들 겁나 한국어 잘해… - YouTube

[This was the same video I went to last night when Alexander_Cabanillas posted, and it was fine with the machine translations. It was fine, and now it’s not.)

At first, I was on Netflix watching with no problem (still no problem there—at least for me and with a TL of Korean (to English translation). For example:
Show Link: [Not Sure How to send a link of an episode of a Netflix show, but it’s episode 15.]:

But I went to Netflix and noticed the above [first screenshot of the YouTube video].

And if I go to this video with Human Translations on Youtube, it appears to be fine for both human and machine translations:

Video Link: Run BTS! EP. 1: [Open] - YouTube

I hope this helps the devs narrow down the issues or something.

Similar bug reports (ongoing list):

@Alexander_Cabanillas I think it might be fixed now. I got the heads up from another LR member and checked myself, and all the test videos I ran again seem to have translations instead of " - " now.

Nope. Still not working here.

Youtube’s official automatic translation doesn’t work either. I don’t know if it’s related to it. Now LR shows ‘-’ no matter what language it translates. When will this bug be resolved?

Strange, yes; maybe if Youtube’s automatic translation is having issues and you’re not a Pro LR user, that is making LR display the " - " ? (Not sure I am a relatively new user—since July-ish)

Are your settings for LR on “Human Translation,” or is your “Machine Translation” toggled on?

LR can only pull what the Source material has for subs, but for pro users, the “machine translations” can be toggled on to show translations generated from the original language in the video.

But, if the subtitles uploaded by the Youtuber/original uploader of the video messed up the subtitles or properly labeling the language of the video, it will result in the translations getting messed up by both Youtube automatic translation and LR’s machine translation (plus the “human translation” option, if the translation is really just the auto-generated version of subtitles from YouTube).

Edit: I also found this reply on a similar Forum post in #ask-the-community that goes into some further detail: youtube translation language not showing up - #23 by Alx02