Furigana not properly displayed

I saw some images of LLN japanese subtitles where furigana works properly, being displayed above the corresponding kanji. An example is found in this topic, where it seems to work fine.

Here is how it shows for me

I also tested on Chrome’s Incognito Mode, with only the LLN extension enabled, and the issue still appears

The default Netflix subtitles seem to work fine but I can’t show due to image limitations on new user’s posts.

I found one old topics about this same issue, but with no response, named “furigana-placement-in-kikis-delivery-service”

Has anyone found the solution? Or is it working properly for you?

1 Like

Here is the default Netflix subtitle, with furigana placed on top of the kanji
image

With LLN transliteration turned on it looks like this. It seems that the issue lies on dealing with already existing furigana on the base subtitles

image

That’s right, it doesn’t render furiganas embedded in the subtitles specially. It should be possible for them to add a special case for Japanese subtitles and parse the files differently to recreate the furigana.

But personally I think a good alternative that would work with every language that may have weird formatting quirks like this, is to offer an option to keep the original Netflix-rendered subtitles, and only display the custom ones over it when video is paused.
That would also fix the font rendering issue highlighted by my thread which you linked.

Bump! In some shows and movies, sentences are filled with these in line furigana, which makes it incredibly hard to read. For me personally, it makes the extension unusable on these shows.

1 Like