ASR subtitles don't work

ASR does not work at all for me. I want to watch any American show dubbed into Hungarian. So I select Hungarian as the audio language and Hungarian-ASR as the subtitle language. Now I hear the Hungarian dubbed version, but I don’t see any ASR generated Hungarian subtitles. I have tried it with at least 15 different shows and it doesn’t work anywhere. I have also tried with other languages - equally unsuccessful.

One example is here:

I’m watching from Hungary.

UPDATE: I’m now seeing a pop-up notification that says: “Problem fetching ASR subs. NETWORK_ERROR”


Same here. I tried several shows dubbed into Vietnamese but it keeps on saying “loading subtitles” on the screen.


same it says some error


Sorry, there were networking issues, seems I got it all sorted now. Today was bumpy but should be smoother going forward.

The Whisper model isn’t that strong with Hungarian, there will be some mistakes, but with programs with clearer audio it may be acceptable. I’m not sure of the details but Whisper has the equivilent of a strong language model inside it, the erroneous sections might not match the audio but will probably still be grammatical Hungarian… need to double check this though.

1 Like

‘Problem fetching ASR subs. “check-ready”’

Watching from US. and from the Netherlands.


As of last night, the ASR subs are totally working, and even include all of the Audio Description!

1 Like

Wow! That’s so cool!

Edit: I just tried it for a couple shows that didn’t have Korean subs (my target language), and it works well!

As David_Wilkison said with Hungarian, this seems true with regards to Korean (the one I tried and so far as I can tell as more of a beginner learner):

I noticed that using it to get subs of shows in my target language (that don’t have original audio subs)—even though a VPN set to another country might also get me target language subs—means I don’t get every piece of spoken dialogue with the Whisper model. Still, I get enough that it works for me.

P.S. Edit. I also noticed that it can also be used to save (what is *closer to*) full sentences (or at least more contextualized phrases:



Can sb help me how this ASR are different from Netflix subs?!
I see that you are using this, but the NF already has subs and dubs for the movie that was provided in the link. So I am struggling with what is going on! Is there a feature that I missed?

Subtitles sometimes not match with the audio in regular subtitles. (Subtitle translators on Netflix usually not using same translation in dubbing) That’s why ASR is different. Maybe also this option would be more effective in youtube as sometimes them not have right language auto subtiles.

  • Still as netflix usually has subtitles already I would prefer this option works all html5 videos (of course it will need more power) for example my favorite site for watching russian movies not have subtitles usually.
1 Like

Doesn’t work for me either. I’ve tried Star Trek Voyager in German so far. It just shows that the subtitles are loading, but nothing happens.

Hi @nekdo123,

I have noticed that for some of the shows I’m using ASR subs for, they say, “subtitles are loading” for a bit longer (i.e., not super-quick).

After waiting a bit longer or refreshing (and sometimes waiting a bit longer), that message goes away for me, and the subtitles come up. (Note: I usually keep the show paused until they’re loaded up.)

Some shows are faster at loading the ASR subs than others.

I am seeing the message ‘Problem fetching ASR subs. “check-ready”’ today. The ASR subs never load. I’ve tried refreshing the page and waiting it out without luck.

Video: Dragon Prince on Neftlix
Language: German
My country: U.S.A.

1 Like

Same thing is happening to me. It’s the only reason I got Pro :frowning:

1 Like

Hey all. Very sorry :frowning: I took a server offline for maintence early this morning, and a network cable was left unplugged. I don’t have notifications set up for the ASR server, so I didn’t realise. It should be working again. I’m shuffling things round, and putting in redundant machines, to get everything super-stable.


No worries! It’s working for me again. Thanks for the quick fix.

1 Like

Seems to be happening with Spanish ASR on Netflix


Just signed up specifically for ASR. Have tried to get French ASR subs for the movie “Zom 100” about 10 times and each time I get:

Problem fetching ASR subs. “check-ready”

Movie: Zom 100
Location: USA
Dubbed language: French
Subs requested: French ASR

I also tried using a VPN to move my location to France. There, I could get French ASR to work for “The Walking Dead” but not “Zom 100”

1 Like

I’m not 100% sure, but for the most part I have noticed that ASR usually has issues when their servers are having issues.

It usually clears up after the developers notice and say something, but it does happen from time to time.

Just my experience as a member/user of the LR forum.

P.S. Still, always good to bring it to the devs attention with post like yours.

1 Like

This error is also coming up for me now: Problem fetching ASR subs. “check-ready”

From: Mexico
Series: Avatar: The Last Airbender
ASR Language: Turkish


same,in Netflix
From : Netherlands
ASR LAnguage : German
i hope, this will be fixed soon.